Network not being connected on iOS

I have kodi installed on my non jailbroken iPhone, it used to work as good as Kodi works,
But suddenly no channel, repository or nothing works, I always get the medsahe
Of the network not being connected... and have no Idea what the issue is... I went from watching nfl games .. to
Not being able to watch 1 single channel movie series.. nothing... can someone help me?
I already uninstalled it. And tried to install the addons again but cant... ill add a screenshot..
i do have internet connection ( on my phone...) and already checked the cellullar data enabled box.
I'm thinkong my carrier might have something to do with it... but havent even used that much data for it to be a problem.
Anyways I hope someone can help me
Ps. I use the kodi version offered by Builds_io
Ps2 don't know how to add the screenshots. Hehe[/php]

Sort Title

I find that the Sort Title is not able to be changed for a movie. My example is the movie "London Has Fallen". It does not appear under L as I would think, but under O for "Olympus Has Fallen", which is the name of the series it is assigned. The Sort Title appears to be directly tied to the assigned series and its number within the series. Is there something I might be missing? Specifically, is there a way I can change the sort title so a sort by title listing appears in order of title?

Movie not scraping

I just added Mobile Suit Gundam Thunderbolt December Sky to my library and it's not scraping any if the info for the movie using the universal movie scraper on Kodi V16. When I decided to give Kodi V17 Beta 2 a test drive it scraped the movies information just fine. The only differences between the two setups is that V16 uses a MySQL back end and the test setup of V17 had my media folder added to it as sources.

I've removed this file multiple times renamed it multiple times and always got the same result.

How can I get this movie scrapes properly so that my database is fully up to date and prepared for when I finally connect Kodi V17 to it?

UWP version – trouble w/multiple display DPI’s

I have a pretty elaborate setup and I get if this isn't the highest priority in the world for you guys... but this may be affecting others and I'm happy to help troubleshoot.

I have 4 monitors. 3x 1920x1200's with a 4K TV centered above (occasionally on) hooked upto a single GTX 980 Ti. I like to get as much text on the screens as I can comfortably read, so the 'Change the size of text, apps, and other items' option in display properties is set to 100% for monitors 1, 2, and 3 (1920x1200's) and 150% for monitor 4. With this setting, the size of things is consistent and the resolution on the 4K screen looks as though I have 4x 1920x1080 screens at 100% (hope this makes sense).

What I have typically done in the non-UWP versions was use WIN+SHIFT+LEFT/RIGHT to move Kodi to different screens. In the non-UWP version, when I moved from a [email protected]% DPI to a [email protected]% DPI, the Kodi UI would adapt and everything was nice and easy. In the UWP version, when I move the app onto the 4K/150% DPI screen, I see the this:

[Image: Kodi_Problem.png]

If that's not rendering correctly... I see the top left corner of Kodi on the top 4K screen over-zoomed.
... and the rest of the interface, over-zoomed (@150%) spanning pieces of the bottom 3 screens (starting 80% across screen #1 and extending beyond screen #3). I can't see the top-right corner of the UI at all as the interface is over-zoomed.

The problem exists even without WIN+SHIFT+LEFT/RIGHT... Anytime I try to set the Dispaly Mode to Full Screen #4, it automatically goes to 3840x2160p and I'm over-zooedm.

MythTV PVR on Openelec/Libreelec?

Using a RPi2. Running mythtv backend from Ubuntu 16.04--it says it's still 0.28 (2:0.28.0+fixes.20160413.15cf421-0ubuntu2), but after an update I was getting API mismatches. Updated Kodi on the Ubuntu frontend, all worked well. Trying to do the same on my RPi2, which was using an Isengard Openelec build. I'm trying to get to the latest mythtv pvr addon, and am trying to use either the libreelec 7.0.2 or 8.0 builds. The latest official OE build didn't work. Where is the pvr addon? Do I need to install a special repo, is there a compiled version somewhere, or is this something I need to build from source (which I REALLY don't have time to mess with)? If it's source, is there an OE/LE build that has a recent PVR add on that I could use? Thanks!

Recommended Netfix + Spotify + DLNA 1080p Box?

I'm looking at retiring the multitude of media players we have here at home with a single all-in-one solution. At the moment, neither of the boxes we have can play Netfix, Spotify, and the various files I have in my DLNA NAS (FLAC seems to be a complete no-go on one box for example).

I only need 1080p support right now as I don't have a 4K TV. My amp is a rather old 2003 Denon AVR-2803, so I don't need pass-through of the latest audio formats.

As I need to play Netflix and Spotify, I'm thinking I'm going to need an Android box (from what I can tell, there are no officially supported Kodi plug-ins that will enable playing of DRM Netflix/Spotify/etc. content)

I have the skills and tools to build new firmware images from scratch, so the Raspberry Pi, ODROID, et. al. would be perfectly fine, except that a) I want a box that looks professional, and b) I would like a nice remote that comes with the box.

So basically, I'm after the best bang-for-buck 1080p device that will handle any video and audio format that I throw at it which looks good and has a nice, usable, remote.

Hardware Features Spreadsheet

Hi Guys,

Not sure if anyone has already done this, but I'm working on a spreadsheet to summarise the popular hardware devices and features people look for in a Kodi device. The current version of the spreadsheet can be found HERE. It's very much a WIP and is missing lots of hardware and features. I've basically done a quick scrape off info from the various forum posts.

Ultimately I would love to get this spreadsheet into a state where it can be added to the wiki to give new users a better idea of which hardware they should look at given a particular set of requirements.

Please PM me any changes I should make



Como disse não sei escrever em inglês so consigo ler algumas coisas,gosto muito do projeto,e quero muito em breve contribuir como membro e usuario, mas estou pagando o parcelamento do cartão de credito,e não tenho outro,mas assim que estiver dinheiro disponível no cartão de debito vou aprender fazer transferência bancária boa noite

install errors

Once again I'm out. kodi had worked for a couple days until my addon quit with some kind of error. Now later on I get no kodi opening at all. I redownloaded and when I try to install I get a ton of could not read files errors. It went ahead and did what it did and again a start menu icon but nothing will open. What can I do about these errors to get it to fully install properly? No problems otherwise with this pc. Thanks.

PyVideo: Error when trying to access videos

Kodi 17 on Fire TV Box.


Results from trying to "Get Latest" videos:

17:11:13 T:18446744072322893544  NOTICE: [xbmcswift2] Request for "/latest" matches rule for function "show_latest"
17:11:13 T:18446744072322893544   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ValueError'>
                                            Error Contents: No JSON object could be decoded
                                            Traceback (most recent call last):
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/", line 110, in <module>
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.module.xbmcswift2/lib/xbmcswift2/", line 332, in run
                                                items = self._dispatch(self.request.path)
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.module.xbmcswift2/lib/xbmcswift2/", line 306, in _dispatch
                                                listitems = view_func(**items)
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/", line 74, in show_latest
                                                videos = pyvideo.get_latest()
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/", line 106, in get_latest
                                                items = get_json(API_VIDEO_URL + '/?ordering=-added')
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/", line 54, in get_json
                                                return response.json()
                                              File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.module.requests/lib/requests/", line 808, in json
                                                return complexjson.loads(self.text, **kwargs)
                                              File "/home/jenkins/workspace/Android-ARM/tools/depends/xbmc-depends/arm-linux-androideabi-android-17/lib/python2.7/json/", line 339, in loads
                                              File "/home/jenkins/workspace/Android-ARM/tools/depends/xbmc-depends/arm-linux-androideabi-android-17/lib/python2.7/json/", line 364, in decode
                                              File "/home/jenkins/workspace/Android-ARM/tools/depends/xbmc-depends/arm-linux-androideabi-android-17/lib/python2.7/json/", line 382, in raw_decode
                                            ValueError: No JSON object could be decoded
                                            -->End of Python script error report<--

Thanks. <=)

Duplication of recording icon on guide

i'm noticing on occasions (usually on re-starting kodi) that the recording timer icon is either misplaced or duplicated: see my screen shots:

Below i selected the "Premier League Show" as a series recording and the icon is on the channel above - although the recording is set correctly

This is a series record that has been set for months for "Football Focus", as you can see, it looks like i have a timer set for every channel for that time. although i can confirm i dont!


Windows 10
Kodi 17

Happy to provide anything else that is required....



Kodi goes to Windows store, a question.

First of all let me say congratulations to all in team Kodi, this news seems quite a milestone for the project.
I just have one question (so far), if I install from the Windows store will my settings, addons and library be preserved as they would be by doing an upgrade from a normal download of Kodi or will it be seen as a separate install from my current one?
I've looked on the store and don't see this information displayed.

Modify command on powersave-idle-shutdown


Since my update to Ubuntu 16.04.01 LTS I need to use "shutdown -P" or "poweroff" command to Poweroff my machine.
I dont know why since /etc/defualt/halt sets HALT=poweroff ... but therea are some compareable bugreports in Ubuntu ...
anyway my question:

When I manually shutdown my machine I could define a shutdown command in DialogButtonMenu.xml.That works well.
But .. I normally use the powersaving feature of kodi which shuts the machine down on x-min idle.
How to define the command, which Kodi uses for that?
I believe it's the Callback "XBMC.poweroff()", but I dont know how to configure the behaviour of that Sad

Any help appreachiated!

BR - Disky

Moving Kodi data to sdcard

Hi, Can anyone please help?
I am running kodi 16.1 on fire tv. I can't seem to be able to get Kodi to write data to the sd card.

I have copied the data from " storage/emulated/0/Android/data/org.xbmc.kodi/files" to my sd card

I have made a text file " " and placed it in "mnt/sdcard"

The text file reads " "
I HAVE also tried "".

I then for test purposes rename "sdcard/Android/data/org.xbmc.kodi" to sdcard/Android/data/org.xbmc.kodi1".

Now when I start kodi it loads up a clean version.

I check in the root "sdcard/Android/ " and it has written a new /org.xbmc.kodi file.

Acer Notebook-No Video

Hi all-wondering if you could take a look at this log and advise how to correct
video playback if possible.

Aspire One D257-1880, Windows 7, service pack 1
32 bit, Intel Atom CPU N570

I can play youtube videos on this unit that is wired to a non-smart Samsung tv with
both units displaying youtubr, but not Kodi. I have audio but primarily dark screen
with intermittant swirling colours.

Any suggestion is appreciated!!!!

Force TV Episode order

I'd like to request the ability to manually force a TV episode order within Kodi itself, through the context menu option or something.

Currently the options are scrape TVDB for Aired or DVD order (which I can't seems to get the plugin to do reliably? I also don't want to jump through hoops to set each series as aired/DVD), or manually generate the NFO files and edit each one (which is beyond tedious).

There are several TV series where the episode order should be in the production order for continuity reasons (be them large or small), where the aired order is incorrect and the DVD order is just whatever they dumped on discs and shipped. It's definitely more an an issue while binge watching, which is more common nowadays, and especially with Kodi.

Some examples (which I've somehow managed to land a fair chunk in my collection) are:

-Happy Endings
-Earth 2
-Better off Ted
-Don't Trust the B---- in Apartment 23
-The Mindy Project
-Star Trek - The Original Series
-American Gothic

I know Firefly is correct in the DVD order, and I know others aren't unwatchable, it'd just be nice to have a minor editing feature or something to flag by number or something that's less work than individually generated and edited NFO files.

Mouse position messes up remote

I hope this hasn't been mentioned earlier, but it's been a minor annoyance to me for some time. I'm currently running the beta 2 Krypton release but it's been an issue for as long as I can recall.

If I start up Kodi and my mouse pointer happens to be jammed into a corner of the screen the remote buttons (up, down, left, right on a Logitech Harmony Ultimate) will not respond. I have to move the mouse over the screen somewhere else for button presses to register. Anyone else have this issue? My htpc is running Windows 10 Pro x64 (current build), nVidia Geforce gtx980, 16gb RAM, Skylake i7.

Show TV Seasons for some, not for others?

Apologies if this has been answered, but searching for an answer here and in the Wiki has so far not revealed an answer for me. At least not clear enough for my pea-brain...

Kodi 16.1 (LibreELEC 7.0.2)

I have TV Shows (library view) scraping and showing up nicely but am wondering if I can have Kodi display some shows with season folders and others not. For example:

30 Rock
* All Seasons
Season 1
Season 2
..... etc...


42x01. Vaccines Calling the Shots
42x02. Rise of the Hackers
..... etc...

So, show NOVA as though it were a single season TV show, sort of.

Yes, I know I can choose the *All Seasons view in NOVA, but I actually would like to toggle that setting off in all TV shows, and I do know where that setting is.

FYI, my entertainment TV shows (30 Rock etc) are on one media share and TV documentary series are on another media share. It's just the TV documentary series I want to do this with, show all episodes directly under the title.



buffering and lagging streams

Hi There,

I am having huge trouble getting to work with Kodi 16.1 or Kodi 17 (almost all versions) with simple iptv and HD 1080p live streams.
And also with some downloaded standard 1080p download streams (not live)

How is this possible? Tried almost everything but it's not working.
Tried with and without codecs on (tried 5.1 and 4.4 android box) tried wired and wireless connection.

Adjusted Router settings. Adjusted advancedsettings cache settings (i know kodi17 has differtent tags) doesnt seem to work at all.

And strange thing is that MX player can play these streams without any problem?! What is wrong with the video player from kodi?

Any developer team member know these issues?

Also for a desperate action tried to use external player tag but even that is not working Sad

Playercorefactory.xml lunch activites?

I am trying to get ES video player to work with Kodi, but I can find no way to do it. ES Video player is just an activity of ES File Explorer, and just having it launch the "" (or any activity I saw in ES) doesn't do anything. I have tried using am, like is in the android playercorefactory.xml example in wiki, to no avail too.

Anybody have any ideas? Or is this not doable?

Failed to install add-on from zip issue!

Everytime I try and install a new update for the Metropolis skin I get a message that says "Failed to install add-on from zip" and so I need to shut down Kodi 17 and restart and then and only then the kin update will install. I seem to have this issue everytime I try and install an skin Metropolis skin update.

Here is info that was recommended to share with you.

12:31:41 T:4612 DEBUG: CAddonInstaller: installing from zip 'smb://BEDROOM-PC/Desktop/Metropolis 3.4.0 RC 3 for Kodi'
12:31:41 T:4612 DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x0000, modifier: 0x0
12:31:41 T:660 ERROR: XFILE::CFile::Delete - Error deleting file C:\Users\Michael\AppData\Roaming\Kodi\addons\skin.metropolis\media\Textures.xbt​​
12:31:41 T:660 ERROR: XFILE::CFile::Delete - Error deleting file special://home/addons/skin.metropolis/media/Textures.xbt
12:31:41 T:660 ERROR: XFILE::CFile::Delete - Error deleting file C:\Users\Michael\AppData\Roaming\Kodi\addons\skin.metropolis\media\Textures.xbt​​
12:31:41 T:660 ERROR: XFILE::CFile::Delete - Error deleting file special://home/addons/skin.metropolis/media/Textures.xbt
12:31:41 T:660 ERROR: CAddonInstallJob[skin.metropolis]: could not read addon description of special://home/addons/skin.metropolis


SuperSU permissions


Should Kodi 16.1 running on Android 5.1.1 ask for superuser permissions?

The reason I ask is I have a portable HDD connected via USB and kodi cannot write to it yet android can with es file explorer, and this is the only reason I can think of that kodi can't write to it

Unless anyone knows better

TIA for any help on this as is driving me a bit nuts here