repositories

I am trying to understand addon.xml found in repos. It is quite logical except 1 thing; let's see this in example:

Code:
    <extension point="xbmc.addon.repository" name="WhiteCream repo">
        <dir>
            <info compressed="false">https://offshoregit.com/tvaresolvers/tva-common-repository/raw/master/addons.xml</info>
            <checksum>https://offshoregit.com/tvaresolvers/tva-common-repository/raw/master/addons.xml.md5</checksum>
            <datadir zip="true">https://offshoregit.com/tvaresolvers/tva-common-repository/raw/master/zips/</datadir>
        </dir>    
        <info compressed="false">http://offshoregit.com/whitecream/addons.xml</info>
        <checksum>http://offshoregit.com/whitecream/addons.xml.md5</checksum>
        <datadir zip="true">http://offshoregit.com/whitecream/</datadir>
    </extension>

As you can see there is extension point that defines repo and name and under it is "info" which points to the addons.xml file. OK, so far so good. BUT! There is a <dir> tag which ALSO contains info tag which points to another addons.xmlConfused

What is the difference between two? If I just need content of a repo, which do I use, ine under <extension> or one under <extension><dir> Confused

Thanx!

D.

Help with Skin Settings.

Hi,

When I add my custome menu to the main menu (News) and I select my super faviourite folder items I am unable to see them when my item (News) is active. I want it to show all my News channel stream Icons appeared when my custom menu (news) is active. Now I have to click News to get icons of my channels from Super faviourite folders.

Any help would be much appriciated. As i tried different settings in skin\menu shortcuts but was unable to achieve.

Thanks.

Shah

H96 pro 4k problem with amp

Apologies if this isn't the right section

Based on s912 chipset & andriod 6

I have Sony tv and Sony amp connected

When I shutdown the box and switch over to the satellite it some how messes with the amp and says " Audio systems communications failure TV speakers active" if I switch the andriod box back on whilst watching satellite the audio system comes back on and says "audio system active"..


So obviously the box itself is sending some command to the amp..I have tried the hdmi cec settings on the andriod on and off and no difference..

Any suggestions?!

Windows PVR backend that can record in multiples from a single tuner

I have Media Portal installed as a PVR backend at the moment and it's working fine.

My only problem is that when beginning a recording from a channel who's frequency already has a tuner attached to it recording a sister channel, rather than recognising that and sharing that tuner to extract both channels from the frequency Media Portal will instead enlist a new separate tuner, limiting the number of channels I can record to the number of tuners I have installed.

WinTV 8 however when faced with the same problem WILL use the already available tuner to extract multiple channels, so I know it's possible, however WinTV 8 can't be used as a backend for Kodi.

So the question is, so that I don't have to install each one and test them, are any of the Kodi PVR backends capable of recording multiple channels from a single tuner when they share a frequency?

Remove Nightly Version 1.8 Kodi

Good morning to everybody,
I need your help to identify which is the right series of command to remove Nightly Kodi 1.8

I did several time :
sudo apt-get update
sudo apt-get remove kodi*
sudo apt-get purge kodi*

but when i reinstall Kodi , it starts with 1.8 and also "aptitude show kodi" points to 1.8

Can you please suggest the step by step to remove totally kodi and so allow from scratch reinstallation of 1.6 or 1.7 ?

How To Enable Watershed Parental Controls?

Wow, first post in 10 years! I was a user of the original XMBC on a few modded Xboxs, and it’s been literally that amount of time since my last post (10 years and 1 day)– thanks for keeping my account and continuing to build a great service ;-)

I’ve just returned to the fold and my household situation has changed over that period. I now have kids using Kodi, and I was wondering is there a way to setup the parental controls so that any recordings after the Watershed (in the UK broadcasters don’t show any content inappropriate to kids before 9pm) to have the parental controls enabled? E.g. Any recordings on BBC1 before 9pm they can watch on recordings, but any after are blocked by the pin?

At the moment I can only see a way to block the whole channel (live and recorded), whereas some channels I want my kids to be able to watch live and recordings before 9pm. The problem I’ve got at the moment, is that recordings we make on other devices via the DVBlink PVR addon are showing up in their profile and are watchable.

STBs from Sky, Virgin and BT tackle this by either putting PINs on any recordings made after 9pm or using the content rating from the guide.
Thanks in advance for any help.

I want legal stuff – Canada QC

Hello Kodi users!

So I found on Amazon.ca some nice Android TV Box preloaded with Kodi (Nothing illegal there I suppose), It comes also with Amazon and Netflix. Comes with 2GB of RAM and a nice 8 Core CPU, can read 4K, etc.

Right now I'm running OSMC on my Rasp Pi 3 in my room, the Android Box will be for my living room.

- Al Jazeera have live tv from their website, can I safely add this to IPTV Simple Addon? Is it legal?
- Some other public channels in my province are also available live on their website, can I take wireshark to find the url and add this to my Kodi? (There is no ads on their website, only on the live channel itself)

- Is there some IPTV provider in Canada that offer Live TV for Kodi? I found some but they require their own box and I cannot install other apps, I want an HTPC like experience)

- Looking in my favorite search engine (not g00gle Wink ), I found plenty of live IPTV services for like 30$ a month, how do I know which one are legal and which one are not?

Thanks for your help guys! Keep the good work! I"m using XBMC since 2007 Big Grin

Add-ons navigation structure improvements

Yesterday I tried to search for an add-on and noticed that it's unnecessarily complex to reach the search option.
Also the entire navigation structure is confusing because when you go "back" from a section as you then end up inside "Add-ons / All repositories" and not where you started.

To find "search" I have to:
1. go to "Add-ons"
2. click on "download" on the left hand side which takes me to "Add-ons / All repositories"
3. click on the ".." back icon
4. now you get "My add-ons", "Install from repository", "install from zip" and "search"

Suggestions:
1. Add a "search" button directly inside the "downloads" section
[Image: vTW9qRb.png]

2. when I click at an element on the right hand side of downloads, and then go "back" then take me back to the "add-ons" section and not "Add-ons / All repositories"
[Image: H5L7JIu.png]

How to display PlayerProcessInfo?

this used to be called CodecInfo
How do we display this information in Estouchy?
Im using an andriod tablet. 6.0.1 API Level 23 w/ AArch64

I'm getting used to skin in general. Havent tried any other touch options. Good layout and buttons are good for the touch screen. So great job devs!

But tying to test a tablet on network. Would be really nice.
Any suggestions?

Kodi 17 won’t connect to Windows SMB

I use a Google Nexus 7 Gen 2 running Android version 6.0.1. Kodi 16 was running great and connected automatically to my Windows 10 network (Windows SMB). I upgraded to Kodi 17 and now it will not connect to my Windows SMB. I get a timeout error. I tried adding the network manually by giving it the SMB's name but it also could not connect. Yes, my wifi network is running just fine.

Any help would be so greatly appreciated.

TV Power off when streaming -> System crash

Hi,

Problem quite easy to reproduce: Watching live TV via TVHeadend/HTS add on. Power cycle TV. When display gets active, only a black screen and system is unresponsive.

Setup: Kodi running on Xubuntu 16.04 - processor is Intel N3150

Problem started after moving to version 17 of Kodi.

Debug log here

First, I suspected it to be relating to enabling the CEC option of stopping playback on TV Power off. But disabling this option did not change behaviour to the better. Looking in the logfile, problems point towards graphics setup.

Any help appreciated :-)

Incorrect Air Date on TV Widgets

Working with the latest Titan beta on Kodi Krypton I've come across an issue I can't seem to resolve. When using the Skin Helper Service widgets, TV episodes (recent/next episode) display the incorrect date.

[Image: ARATl7YwG.png]

If I swap out a Skin Helper Service widget with a playlist I create it will display correctly (same episode in both screenshots)

[Image: ARCi2ypbW.png]

I would be fine with making playlists to resolve this but it's impossible (at least from what I can see) to make a "Next Episode" playlist that duplicates the Next Episode Skin Helper Service Widget.

Any ideas?

Black Screen on Startup

Hi,

I recently put a new mobo/processor/ram into my computer. I kept my old windows install by using 'sysprep'. Basically it's a tool that removes all the drivers from your installation of windows so that an IT person can distribute a preset installation of windows onto many computers. I used it to keep my installation working when I switch a lot of hardware....

So everything is working now and I believe that I have all my drivers installed. The only issue is that when I start Kodi I get a black screen.

I tried uninstalling/reinstalling. I deleted all the setting in /appdata/. Deleted all the files in /program files/kodi, etc.

But when I start Kodi it goes to a black screen and never goes anywhere.

I posted on the reddit.com/r/kodi subreddit and they recommend I turn on debug logging and upload it on pastebin.

So here is my logfile. Looking through it I didn't see anything that stood out significantly. I will try reinstalling my video driver and reinstalling Kodi again and see if that gets anywhere.

http://pastebin.com/WNGCdwnK

Win10 SMB Issues – Shares are for Nvidia Shield TV

Hi folks,

I'm running Windows 10 Pro on my awesome new little Intel NUC6CAYH (pimped out about as much as you can pimp out a Celeron mini-PC...8GB 1866MHz RAM, 1TB HDD). For my media, I have an external 4TB HDD, which I've shared my various media folders from. Anyway, I'm having SMB issues. I followed the Kodi SMB setup Wiki to a T after I first ran into trouble. I am now using the Windows 10 Homegroup method as Kodi prescribed :-) but I'm still having issues.

I'm trying to connect to the shares from my Nvidia Shield TV in another room. When I browse and choose SMB as a source, I see "WORKGROUP" which I know is the default, and I haven't changed that. If I attempt to go into "WORKGROUP", it just times out.

I have the NUC set to a static IP within my home network, which makes things a little easier. The house/internet devices are 100% Cat6 + Gigabit Ethernet router/switches.

The Shield TV SEES the NUC when I navigate to settings ---> Network storage outside of Kodi to mount a Network Storage device, but when mounted, it only shows one shared folder... "Users". Usually it shows a list of all top-level shared folders.

I've literally spent 5 hours between today (about 2 hrs) and yesterday (about 3 hrs) troubleshooting and I'm at my wits end. Please let me know if you can help and if you need logs, screenshots, anything...and thank you so much in advance!

split

When I try to watch the new movie Split, directed by M. Night Shyamalan, starring James McAvoy, I get a bowling film. WhyConfused The trailer and the film information is correct, but when I press play, I get the bowling film. Someone should be aware of this and fix. Please.
Thanks, kay

script.extendedinfo and Youtube Daily Limit Exceeded

I am not entirely sure where to put this question, but since it also involves Youtube, this might be the right forum.

I have stopped using the Kodi Youtube Addon because i would always get the Daily Limit Exceeded, when all i had done was install the addon and nothing else but still it would pop the same error 404.

I was just looking through my userdata folder and looked in the script.extendedinfo folder, and saw a folder inside named Youtube there are other folder inside the script.extendedinfo, but this caught my attention, because one of the text file had the
{"error": {"code": 403, "message": "Daily Limit Exceeded. The quota will be reset at midnight Pacific Time (PT).
And then there are a lot of other text files with search text after search text, so i no longer wonder at why i get the Daily Limit Exceeded, when i only installed the Youtube addon, and upon launch would get the 404.

Because the script.extendedinfo, which is installed with one of the official skins, is doing constant search on Youtube, prob when i listen to music but it also looks for lyrics and what ever on Youtube.

So i checked the settings file
<setting id="autocomplete_provider" value="youtube" />

So am i right in believing that its the script.extendedinfo, pulling search off for what ever that is giving me the Daily Limit Exceeded,
Now i have not been logged into the Youtube addon, but the script.extendedinfo is still searching youtube for lyrics?, statistics? and prob when a Music file is not tagged right, because some of the text search was for stuff i would not be caught dead listening to.

Now i think i remember you can change the autocomplete to google instead would that fix the daily limit or because Google own Youtube still give me a head ache i think the script.extendedinfo comes from the skin Rapier, if i remember right i got a msgbox in order to use this what ever you need to install script.extendedinfo, i always hated that, but i also like the Rapier skin, and the def kodi skin is giving me a headache.

So am i right in assuming, that the script.extendedinfo is the reason i get daily limit error, after i install the youtube addon.

I hope my question is understandable, and i am posting in the right forum
Thank You

Red Mute Button

Hi, I'm new to Kodi and have just recently installed kodi 17. I have no audio and there is a red mute logo in the top right corner, I have watched on YouTube how to get volume if I have it Kodi on a computer however my Kodi is installed on my Samsung Galaxy S7 and there is absolutely nothing on YouTube to solve my problem, any ideas please?

ServerWMC crashes after pausing recorded TV

I am a newbie for Kodi. This is my 1st post. I have a fully functioning WMC setup that works with WMC extenders. I have a 2017 Nvidia shieldTV Pro. I have installed ServerWMC installed for front end and backend.

Problem:
Launch ServerWMC android app --> Start Recorded show --> Pause show around 15-30 seconds --> Press Pause againg --> Show will play for around 1-2 minutes and then it will stop and go back to main serverwmc menu.
-- This has same behavior for live TV.

Equipment:
- windows 7 quad core processor 16 gb ram - Gigabit wired connect - runnint ServerWMC backend
- Ceton 6 tuner - Gigabit wired connect - Running Kodi Krypton from playstore.
- NvidiaTV Pro - Gigabit wired connect - running serverWMC front end

Logfile:
https://paste.ubuntu.com/24037634/

Any help would be appreciated thank you

SHIELDTV-FUN.

Live build failure

For some time now my git build fails with:
Code:
[ 18%] Building CXX object build/filesystem/CMakeFiles/filesystem.dir/iso9660.cpp.o
cd /home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999_build/build/filesystem && /usr/lib64/ccache/bin/x86_64-pc-linux-gnu-g++   -I/home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999 -I/home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999/lib -I/home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999/lib/gtest/include -I/home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999/xbmc -I/home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999/xbmc/linux -I/home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999/xbmc/cores/VideoPlayer -I/home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999_build/build -I/usr/include/freetype2 -I/home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999_build/build/cpluff/include -I/home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999_build/build/libdvd/include -I/usr/include/lzo -I/usr/include/libxml2 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/python2.7 -I/usr/include/libdrm   -march=native -O2 -pipe -fgraphite-identity -floop-interchange -floop-strip-mine -floop-block -std=c++11 -gsplit-dwarf   -D_LINUX -DTARGET_POSIX -DTARGET_LINUX -DHAVE_SSE=1 -DHAVE_SSE2=1 -DHAVE_SSE3=1 -DHAVE_SSSE3=1 -DHAVE_SSE4_1=1 -D__STDC_CONSTANT_MACROS -D_FILE_DEFINED -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_STD__U16_STRING=1 -DHAVE_STD__U32_STRING=1 -DHAVE_CHAR16_T=1 -DHAVE_CHAR32_T=1 -DHAVE_STDINT_H=1 -DHAS_BUILTIN_SYNC_ADD_AND_FETCH=1 -DHAS_BUILTIN_SYNC_SUB_AND_FETCH=1 -DHAS_BUILTIN_SYNC_VAL_COMPARE_AND_SWAP=1 -DHAVE_INOTIFY=1 -DHAVE_POSIX_FADVISE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_INTTYPES_H=1 -I/usr/include/fribidi -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DFFMPEG_VER_SHA=\"3.1\" -DHAVE_MYSQL=1 -DHAVE_LIBXSLT=1 -DHAVE_ALSA=1 -DUSE_ALSA=1 -DHAVE_LIBUDEV=1 -DHAVE_DBUS=1 -DHAVE_LIBVDPAU=1 -DHAVE_LIBVA=1 -DHAS_PYTHON=1 -DHAVE_LIBNFS=1 -DHAVE_OPENSSL=1 -DHAVE_LIBGL=1 -DHAVE_X11=1 -DHAVE_LIBXRANDR=1 -DHAVE_LIBEGL=1 -DBIN_INSTALL_PATH=\"/usr/lib64/kodi\" -DINSTALL_PATH=\"/usr/share/kodi\" -std=c++11 -o CMakeFiles/filesystem.dir/iso9660.cpp.o -c /home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999/xbmc/filesystem/iso9660.cpp
In file included from /home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999/xbmc/filesystem/iso9660.cpp:47:0:
/home/portagetmp/portage/media-tv/kodi-9999/work/kodi-9999/xbmc/filesystem/iso9660.h:35:26: fatal error: cdio/iso9660.h: No such file or directory
#include <cdio/iso9660.h>
                          ^
compilation terminated.
make[2]: *** [build/filesystem/CMakeFiles/filesystem.dir/build.make:711: build/filesystem/CMakeFiles/filesystem.dir/iso9660.cpp.o] Error 1
All hints are appreciated.